Back to overview
Downtime

⚠️ Ongoing Incident — Cloudflare Network Outage

Nov 18 at 11:07am EST
Affected services
Website
API
Push Notifications
CloudFlare

Resolved
Nov 18 at 02:05pm EST

Cloudflare services are now operating normally. We are no longer seeing elevated errors or latency across the network.

Their engineering teams continue to monitor the platform closely and are conducting a deeper investigation into the earlier disruption. No configuration changes are being made at this time.

At this point, it is safe to re-enable any Cloudflare features that were temporarily disabled during the incident. We’ll provide a final update once Cloudflare completes their investigation.

Thank you for your patience throughout this outage. 💜
— The Clubly Engineering Team

Updated
Nov 18 at 11:29am EST

Cloudflare has reported continued improvement in both errors and latency, though some intermittent issues are still being observed. Their team is actively monitoring the situation as it improves and is exploring ways to accelerate full recovery.

We will continue to track Cloudflare’s progress closely and provide updates as the situation develops.

Thank you for your patience. 💜
— The Clubly Engineering Team

Created
Nov 18 at 11:07am EST

We’re currently experiencing service disruption due to a major Cloudflare outage affecting DNS, proxy routing, and edge connectivity. This issue is impacting multiple platforms globally and is causing intermittent failures across Clubly services.

Some users may see:
• Pages failing to load
• API errors
• 522/502 connection issues
• Slower-than-normal performance

Our infrastructure remains healthy — the disruption is upstream at Cloudflare. We will continue monitoring the situation closely and will restore full service as soon as Cloudflare resolves the incident.

Thank you for your patience and understanding while we navigate this outage. 💜
— The Clubly Engineering Team